David Overton's Blog and Discussion Site
This site is my way to share my views and general business and IT information with you about Microsoft, IT solutions for ISVs, technologists and businesses, large and small. I specialise in Windows Intune and SBS 2008.
This blog is purely the personal opinions of David Overton. If you can't find the information you were looking for e-mail me at admin@davidoverton.com.

To find out more about my Windows Intune BOOK - Microsoft Windows Intune 2.0: Quickstart Administration click here

To find out more about my SBS 2008 BOOK - Small Business Server 2008, Installation, Migration and Configuration click here

Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
David Overton's Blog

Buy my books

Windows Intune:Quickstart Administration


This is the RAW book (Read as Written).
Click here for more information
Buy or pre-order today

SBS 2008 - Installation, Migration and Configuration

Small Business Server 2008 – Installation, Migration, and Configuration

Buy today in book or e-book form

Request a Review Copy

Twitter

Syndication

I had some apps fail on my machine yesterday after I got back from the TechNet event, so off I went to diagnose.  It was then that I discovered that the help and support service had gone.  Vanished, Vamoosh.  I did find this little baby in the event log though:

 

Event Type:        Error

Event Source:      HELPSVC

Event Category:    None

Event ID:          16387

Date:              14/03/2007

Time:              11:44:31

User:              N/A

Computer:          SERVER

Description:

Service could not be deleted

Being of a speedy nature I fired a mail off internally only to be told "yep, we know about and are investigating and we have already blogged about it" - http://blogs.technet.com/sbs/archive/2007/03/20/help-and-support-service-missing-after-installing-windows-2003-service-pack-2.aspx

There is a fix there, which I used, works and is great, so no harm done, just a small panic.


Posted Wed, Mar 21 2007 2:12 PM by David Overton

Comments

David Overton's Blog wrote Small Business Server 2003 (SP1 and R2) upgrading to SP2 and Internet Explorer 7 (IE7) information - including the fact that you do NOT have to uninstall IE7
on Wed, Mar 21 2007 2:16 PM

[updated 21th March 14:15] This is just a quick note to say that the release notes are WRONG (and will

Paul Cauwe wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Thu, Mar 22 2007 2:47 PM

I reapplied the servicepack and the problem was solved

VenuGopal.P wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Wed, May 16 2007 6:32 AM
Thanks David. It works fine. But how come Help and Support service disapper from the services.msc?
Grant Strong wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Fri, Aug 17 2007 8:48 PM

I've been having a rough go of it today with Exchange ActiveSync, that nasty 3005 event error (any tips for that), so thanks for the quick fix on this one or else I'd have no hair left to pull out.

Prakash Tulsiani wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Thu, Oct 4 2007 7:51 AM

Geeks,

Thanks a lot !!! It worked for me on Windows 2003 Server. It was same thing here, Help & Support services dissapeared after SP2.

Best regards,

Prakash

tulsianip@gmail.com

Josko wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Thu, Nov 29 2007 11:15 PM

Thanks, this solved my problem.

For serbian IT's

Problem Help and support service ne radi neradi, ovde imate resenje

Andy Macdonald wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Thu, Dec 13 2007 10:23 AM

Thanks

Srini Lokula wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Thu, Jan 10 2008 1:27 AM

The link worked, Thank you.

ravindra sudehely wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Wed, Apr 30 2008 6:33 AM

that's great it solved my problem of help and support services missing

Jason wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Thu, Aug 28 2008 3:34 PM

Thanks a lot. The link and fix solved it for me.

Karen wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Wed, Nov 12 2008 11:40 AM

The problem is not just on SBS I am running 64bit Enterprise and still had the problem  The link solved it, so thanks a lot.

Gil Virtucio wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Mon, May 25 2009 3:42 AM

Worked like a charm :) thanks for the help...

C:\WINDOWS\PCHealth\HelpCtr\Binaries> start /w helpsvc /svchost netsvcs /regserver /install

elements5th wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Tue, Jun 16 2009 9:44 AM

thanks for the help but my problems not solved. navigation command works well i.e %windir%\pchealth\helpctr\binaries . after reaching to this directory when i am running command from run menu "start /w helpsvc/svchost netsvcs/regserver/install" does not work and give error message windows cannot find start , make sure your typed name is correct and try again. Pls let me know how to execute this file to solve this problem

Eric wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Fri, Sep 25 2009 5:44 PM

Thanks for the tip that worked just fine

Steve B wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Thu, Jun 3 2010 4:28 PM

After trying all the other "fix"'s and also the Hotfix download from MS Kb937231 which also failed.  I came across this website.  Entered :C:\WINDOWS\PCHealth\HelpCtr\Binaries> start /w helpsvc /svchost netsvcs /regserver /install

AND hey Presto, everything works OK again

thanks muchly

Anonymous wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Mon, Jul 26 2010 12:10 PM

indeed helpful. thanks a ton mate

Tom T wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Tue, Sep 7 2010 11:58 PM

I just tried your solution and it worked fine.

However, save time and copy and past this line once you have made it to the binaries directory.

start /w helpsvc /svchost netsvcs /regserver /install

The task takes about 30 seconds or more depending on the speed of your system.

Thanks again for your help.

antony wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Fri, Oct 15 2010 8:43 AM

rpc server is unavilable

Anonymous wrote re: Help and Support Service not working / there after Windows Server 2003 Service Pack 2 (SP2) is applied to a machine
on Wed, Oct 12 2011 10:49 PM

This was the fix for me...

support.microsoft.com/.../937231

Add a Comment

(optional)  
(optional)
(required)  
Remember Me?

(c)David Overton 2006-13